AirwaySim
Online Airline Management Simulation
Login
Username
Password
 
or login using:
 
My Account
Username:
E-mail:
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: Up in the Air (2009)  (Read 1264 times)

Offline JumboShrimp

  • Members
  • Posts: 7971
Up in the Air (2009)
« on: May 16, 2011, 06:09:25 PM »
Good thread for this.  Lots of air traveling in this movie:

Up in the Air
http://www.imdb.com/title/tt1193138/

GEnx

  • Former member
Re: Up in the Air (2009)
« Reply #1 on: May 16, 2011, 06:34:11 PM »
Nice, a 7.8. Thanks for the tip. :)

Dave4468

  • Former member
Re: Up in the Air (2009)
« Reply #2 on: May 16, 2011, 06:50:55 PM »
It's a brilliant film, one of my favorites for a long time. But, bar a few panning shots of airports and planes, airports and aircraft are really are just where the film happens, it has little to nothing to do with planes other than that.

Now I shall watch it to procrastinate from revising some more.

Offline mtnlion

  • Members
  • Posts: 485
Re: Up in the Air (2009)
« Reply #3 on: May 16, 2011, 06:59:21 PM »
One of my favorites!

Jps

  • Former member
Re: Up in the Air (2009)
« Reply #4 on: May 17, 2011, 06:11:01 PM »
Very good film, indeed.
I think it shows very well what it's like to travel a lot for business, and also how you can make an 'art' out of it  :laugh:

EYguy

  • Former member
Re: Up in the Air (2009)
« Reply #5 on: May 17, 2011, 11:20:28 PM »
Good movie... My life before coming here was like... I was a Senator for M&M, Lufthansa Frequent Flyer...

Offline MRFREAK

  • Members
  • Posts: 392
Re: Up in the Air (2009)
« Reply #6 on: May 24, 2011, 08:39:48 PM »

slither360

  • Former member
Re: Up in the Air (2009)
« Reply #7 on: May 24, 2011, 08:42:54 PM »
I liked the movie, but there was nothing more classic than http://en.wikipedia.org/wiki/Up_%282009_film%29

Online ArcherII

  • Members
  • Posts: 2131

 

WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.