AirwaySim
Online Airline Management Simulation
Login
Username
Password
 
or login using:
 
My Account
Username:
E-mail:
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: [ok] Manage routes links do not correctly add fleet filter for models  (Read 345 times)

Offline Mort

  • Members
  • Posts: 673
Steps to reproduce

  • Go to the manage routes page
  • Apply a fleet model filter (tested with Boeing 737-200C Adv)
  • Click search routes
  • Click destination view
  • Click on one of the numbers that link through to a further manage routes page under the heading "Routes" (listing all routes for that airport pair)
  • The resulting page does not keep the fleet group/model filter applied (it does keep a base airport filter applied if selected however)

I'm assuming the intended behaviour is that the fleet group should pull through, as there is a filterFleet query parameter in the URL of the linked-to page, for example:

https://www.airwaysim.com/game/Routes/Manage/?filterAirport=3167&filterBase=2689&filterFleet=m-562

A further test, but selecting a fleet group instead of a specific model (tested with Boeing 737-100/200) and the filter does correctly pull through, example URL:

https://www.airwaysim.com/game/Routes/Manage/?filterAirport=3303&filterBase=2689&filterFleet=f-22
« Last Edit: January 02, 2020, 05:08:16 PM by Sami »

 

WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.