Online Airline Management Simulation
or login using:
My Account
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: Hot ‘dam: FlyEurope announces expansion  (Read 178 times)


  • Former member

The 6 people who like this post:
Hot ‘dam: FlyEurope announces expansion
« on: March 05, 2019, 03:12:06 AM »
FlyEurope, an Amsterdam-headquartered airline, announced this quarter its expansion with a new base in Rotterdam. However, the grand opening celebrated today was not always in the works.

“We tried to get permission for flights from Rotterdam to Amsterdam,” FlyEurope CEO slickwillbo said. “We could’ve offered Rotterdam residents convenient one-stop service to more than 75 destinations on four continents,” he continued. However, the local aviation authorities refused, insisting that such flights violated the country’s minimum route length policy. “We tried everything - intelligent arguments, threats, bribes, you name it,” the CEO said. “We just couldn’t get it done. We were dejected.” he stated.

The situation changed at a board meeting several months ago. After the board of directors’ seventh round of Heineken at their weekly Tuesday morning meeting, one executive noted that FlyEurope served more passengers at airports ending in -dam than any other airline. “It’s time for a ‘dam expansion,” he exclaimed.

Construction would prove challenging, as the airline’s plans called for a large base to accommodate sizable planes. The airline’s large external base is one of the first of its kind in Europe. “We had to trim the budget to accommodate the additional construction costs,” the airline’s CFO stated. “We’re happy we only had to skip a few routine maintenance checks to help with construction costs,” said slickwillbo. “The safety of our passengers was never seriously in danger,” he continued.

FlyEurope now offers nonstop service from Rotterdam to ten European destinations.


WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.