Online Airline Management Simulation
or login using:
My Account
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: Bonus for playing to the end  (Read 311 times)

Offline GjedDa

  • Members
  • Posts: 246
Bonus for playing to the end
« on: July 16, 2013, 05:27:19 AM »
In Dotm now big airlines just quit since they dont wanna pay last two weeks credit. And yes, nothing much to do thats for sure. But when game ended pages comes up its just sad reading when there is only 150 out off 460 airlines left.

So i think there should be a small bonus to the airlines that actually plays to the end.

So if a player has spend 20 credits ore more in one game : 5+15 and plays to the end he or she should get 3 credits back. Just a little carrot to keep players ingame so when game ends you can loock at the end resoults and actually know if you did good ore bad.

Offline Mr.HP

  • Members
  • Posts: 2730
Re: Bonus for playing to the end
« Reply #1 on: July 16, 2013, 08:53:00 AM »
Good idea. 15 credits > than 3 months playing so I guess giving back 2 or 3 credits as a reward for the Achievement "To the end"

Thanks to the BK of some big players, now I have tons of leased out A/C returned  >:(

Offline LemonButt

  • Members
  • Posts: 1895
Re: Bonus for playing to the end
« Reply #2 on: July 16, 2013, 05:22:59 PM »
With ultralong gameworlds this shouldn't be an issue...

Offline GjedDa

  • Members
  • Posts: 246
Re: Bonus for playing to the end
« Reply #3 on: July 16, 2013, 05:55:58 PM »
It still will be an issue.

2 gameyears left, your airline is "full and nomore to do"
there is another UL gameworld started earlier so you just bankrupth and quit.
People who base there airline on Leasing planes. something that is possible when there is a Ultra long game will last 5 years sit with 150 plans on the marked since everybody
drops out of the gameworld. "Since there is no point in playing"


WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.