Online Airline Management Simulation
or login using:
My Account
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: [-] Extend allowed aircraft purchase / extend discount for aircraft purchase  (Read 746 times)


  • Former member
With a look on longer gameworlds but not exclusive.

At the moment the highest possible discount (without launch customer) is 26% by purchasing 40x with 100% pre-paid.

Why is this the limit? Why aren't we allowed to purchase up to 100 aircraft, if there bust be a maximum number at all? It would be very nice if the number of aircraft that could ordered at once would be increased as well as the discount.
« Last Edit: November 29, 2012, 12:28:21 PM by sami »


  • Former member
Eventually you will reach the point where the manufacturer isn't willing to sell the aircraft any cheaper.  26% seems to be a reasonable level for that point.

Jona L.

  • Former member
Well, Ryanair got their 738s so cheap, that Boeing wasn't even wanting to disclose the total amount to be payed... rumors went, that it were up to 45-50% discounts

Offline Infinity

  • Members
  • Posts: 1571
Single aisles are nowadays almost routinely sold at a 50% discount, not just for Ryanair.

Offline Sami

  • Administrator
  • Members
  • Posts: 15647
    • AirwaySim - Are you the next Richard Branson?
There has to be some cap at the discount, and currently it is this. No changes are planned (or needed in my mind) for it..


  • Former member
Ok, thanks. What about an extension without a further discount, so to get more than 50 aircraft into launch customer discount? :)

And maybe remove the overall order cap of ~400 aircraft?

Sorry, I'm really claiming today. :P

Jona L.

  • Former member
And maybe remove the overall order cap of ~400 aircraft?

The worst thing in this game, especially when far into a game world....


WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.