AirwaySim
Online Airline Management Simulation
Login
Username
Password
 
or login using:
 
My Account
Username:
E-mail:
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: Douglas Aircraft Company -- asleep at the wheel?  (Read 691 times)

Offline EsquireFlyer

  • Members
  • Posts: 1327
Douglas Aircraft Company -- asleep at the wheel?
« on: July 24, 2013, 02:48:01 PM »
Where are the Douglas Commercial DC-8s?
It's the middle of 1958 and the crappy DC-8-20 hasn't even launched yet.

Meanwhile, Boeing is already selling the biggest, baddest 707-320 and has been for a looong time now.

Offline dmoose42

  • Members
  • Posts: 1264
Re: Douglas Aircraft Company -- asleep at the wheel?
« Reply #1 on: July 24, 2013, 02:49:09 PM »
Didn't you get the note?  Douglas BKed because of poor demand for the DC-8-10...

Offline Troxartas86

  • Members
  • Posts: 877
Re: Douglas Aircraft Company -- asleep at the wheel?
« Reply #2 on: July 26, 2013, 08:38:37 AM »
There is always an element of randomness in when any given model comes into play.

Offline Mr.HP

  • Members
  • Posts: 2730
Re: Douglas Aircraft Company -- asleep at the wheel?
« Reply #3 on: July 27, 2013, 12:16:39 PM »
Didn't you get the note?  Douglas BKed because of poor demand for the DC-8-10...
Oops, is it true? So in JA8, there won't be any DC-8 from now on?  ???

Offline Teadaze

  • Members
  • Posts: 777
Re: Douglas Aircraft Company -- asleep at the wheel?
« Reply #4 on: July 27, 2013, 12:58:28 PM »
I heard HP brought Douglas and then use the facility to make personal computers.

Offline knobbygb

  • Members
  • Posts: 605
Re: Douglas Aircraft Company -- asleep at the wheel?
« Reply #5 on: July 28, 2013, 06:15:39 PM »
Well, as mentioned in the other thread - maybe they're still busy building all those DC6s and recovering from the production run.  If you look at a few dates, at one point they were turning out over 200 per month!

 

WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.