AirwaySim
Online Airline Management Simulation
Login
Username
Password
 
or login using:
 
My Account
Username:
E-mail:
Edit account
» Achievements
» Logout
Game Credits
Credit balance: 0 Cr
Buy credits
» Credit history
» Credits FAQ

Author Topic: CV 880...Anybody have good experiences with them?...  (Read 742 times)

L1011fan

  • Former member
CV 880...Anybody have good experiences with them?...
« on: August 02, 2010, 12:22:47 AM »
I've used them in the past, and I'm thinking I'm going to have to bankrupt my current Jet Age 2 airline (Northern Sun based CLE) and I see many available. Anyone think they might work out? :-\

Offline CUR$E - God of AirwaySim

  • Members
  • Posts: 4028
Re: CV 880...Anybody have good experiences with them?...
« Reply #1 on: August 02, 2010, 01:13:43 AM »
If you look at the airlines all around, you'll see every aircraft will work in Jet Age .... until fuel prices are this low  ;)

minerva

  • Former member
Re: CV 880...Anybody have good experiences with them?...
« Reply #2 on: August 02, 2010, 03:01:12 AM »
I'll leese or sell you one at a big discount....I had three, but they are expensive to acquire, expensive to run (not just fuel costs, look at staff costs too), and have only speed as a virtue.  But really, lease or buy mine, I'm dying to get rid of it (this one has been leased three times before, but all three airlines have B/K'd).


minerva

  • Former member
Re: CV 880...Anybody have good experiences with them?...
« Reply #3 on: August 02, 2010, 12:50:17 PM »
Wrote too soon: an aircraft broker just bought my CV 880 (at 2 Mill below market value).  So, sorry, can't give you that discount.  But my advice -- stay away, stay far away, from the CV 880, unless you have a deep masochistic streak....

L1011fan

  • Former member
Re: CV 880...Anybody have good experiences with them?...
« Reply #4 on: August 02, 2010, 05:05:36 PM »
Ok, Minervas advice is loud and clear to me. I think I'll stay away from that one.

 

WARNING! This website is not compatible with the old version of Internet Explorer you are using.

If you are using the latest version please turn OFF the compatibility mode.